PAT甲级1002. A+B for Polynomials (25)

1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 2 1.5 1 2.9 0 3.2

陌生的单词短语

Polynomials  n.多项式

Be supposed to 意为应该,被期望,理应做某事,主语是物时,他表示,本应做,用于表示某事本应该发生而没有发生 egThe train was supposedto arrive half an hour ago.

Exponents  指数

Coefficients 系数

Respectively  各自的,分别的

Accurate   精确的

Decimal  adj.小数的;十进制的n.小数

Please be accurate to 1 decimal place   精确到小数点后一位


这个题的意思是:就是初中做数学题的“合并同类项”,就酱紫。一开始我的想法是什么呢:建立结构体,

包含(contains)系数和指数,然后把两次的结构存到一个结构体数组里,排序,把相互重复的加起来,等于0的去除掉。确实

些麻烦,并且,我并没有通过全部的样例,所以,我就换了很多博主的那种方法,就是建立一个空间为1000的数组,数组下标为

指数,数组内容为系数,最后遍历两边,第一次遍历找到非零项个数,然后输出,第二次把所有非零项都输出。这个我刚开始也

想到了,之所以没一开始就写,我是担心开的数组会很大,事实上,我觉得如果非零项比较少,并且指数之间相差比较大,这种

方法有点浪费空间,比如,指数只有1和1000,这俩,你还是要开这么大的数组空间,浪费的是比较大的,我之所以想利用结构

体,就是希望能减少空间的浪费。这个最佳的做法我觉得是利用链表。等STL学了一丢丢之后,我重新写,并且把多项式加法,

减法,除法都写一下,特别是除法,去年也就是17年天梯赛的团体赛就有一个题考的是除法。

附代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int k, i, j;
	double a[10005];
	memset(a,0,sizeof(a));
	int num1;
	double num2;
	scanf("%d",&k);
	for(i=0;i<k;i++)
	{
		scanf("%d %lf",&num1,&num2);
		a[num1]=num2;
	}
	scanf("%d",&k);
	for(i=0;i<k;i++)
	{
		scanf("%d %lf",&num1,&num2);
		if(a[num1]!=0)
		a[num1]=a[num1]+num2;
		else a[num1]=num2;
	}
	int flag=0;
	for(i=0;i<10005;i++)
	{
		if(a[i]!=0)
		flag++;
	}
	printf("%d",flag);
	for(i=10000;i>=0;i--)
	{
		
		if(a[i]!=0)
		{
			if(flag!=0)
			printf(" ");
			printf("%d %.1lf",i,a[i]);
			flag--;
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值