湖大ACM-Recaman's Sequence

Recaman’s Sequence
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB
Total submit users: 1547, Accepted users: 1361
Problem 10010 : No special judgement
Problem description
The Recaman’s sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m.
The first few numbers in the Recaman’s Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 …
Given k, your task is to calculate ak.

Input
The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. The last line contains an integer −1, which should not be processed.

Output
For each k given in the input, print one line containing ak to the output.

Sample Input
7
10000
-1

Sample Output
20
18658

Problem Source
Shanghai-P 2004

解决方案:超大数组保存是否使用过该值

代码部分:

#include <stdio.h>
#include <malloc.h>
int main ()
{

    int arr[500001],i;
    int * b=(int *)malloc (4000000 *sizeof(int));
    arr[0]=0;
    for (i=0;i<500000;i++)
       if ((arr[i-1]-i>0) &&((b[arr[i-1]-i])!=1) )
       {arr[i]=arr[i-1]-i; b[arr[i-1]-i]=1;}
       else
       {arr[i]=arr[i-1]+i; b[arr[i-1]+i]=1;}

    int key=0;
    scanf("%d",&key);

    while (key!=-1)
    {
        printf ("%d\n",arr[key]);
        scanf("%d",&key);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值