【pta 甲级】1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
在这里插入图片描述

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

要注意 末尾没有空格,保留一个有效数字,还有隐藏的正数负数相加会抵消
用了map来做,不过好像弄复杂了,就当锻炼使用容器的能力吧

#include<bits/stdc++.h>
using namespace std;
// void i2s(long long x,string & str)
// {
//     stringstream ss;
//     ss<<x;
//     ss>>str;
// }
int main()
{
    int n;
    map<int,float>a;
    map<int,float>b;
    cin>>n;
    int t;
    for(int i=0;i<n;i++){
        cin>>t;
        cin>>a[t];
    }
    int m;
    cin>>m;
    for(int i=0;i<m;i++){
        cin>>t;
        cin>>b[t];
    }   
    map<int,float,greater<int>>c;//通过greater使得map按照key从大到小排序。
    for(auto x:a){
        c[x.first]=x.second;
    }
    for(auto y:b){
        c[y.first]=y.second;
    }
    int f=0;
    for(auto x:a)
    {
        for(auto y:b)
        {
            if(x.first == y.first)
            {
                c[x.first]=x.second+y.second;
                f++;
                if(c[x.first]==0)
                   {
                    c.erase(x.first);
                    f++;

                   } 
            }
        }

    }
    f=n+m-f;
    cout<<f;

    for(auto x:c){

         printf(" %d %.1f",x.first,x.second);

       
    }
    

    return 0;
}
参考资料
https://www.cnblogs.com/lakeone/p/5599047.html     关于map排序

简单一些的方法:

#include<cstdio>
#include<iostream>
using namespace std;
const int maxn = 1111;
double p[maxn] = {};
int main() {
    int k, n, count = 0;
    double a;
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        scanf("%d %lf", &n, &a);
        p[n] += a;
    }
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        scanf("%d %lf", &n, &a);
        p[n] += a;
    }
    for(int i = 0; i < maxn; i++) {
        if(p[i] != 0) {
            count++;
        }
    }
    printf("%d", count);
    for(int i = maxn; i >= 0; i--) {
        if(p[i] != 0) {
            printf(" %d %.1f", i, p[i]);
        }
    }
    return 0;
}
————————————————
版权声明:本文为CSDN博主「会很好笑诶」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/hy971216/article/details/81131297
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值