【ZOJ 1913】Euclid's Game(博弈)

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

题目大意

给你两个整数n,m,每次都可以将较大的一个数(假设总有n>m)n变为n-m*k(k为任意自然数,其中m*k<=n),先将其中一个数变为0的一方获胜。

思路

假设两个数为a,b(a>=b)

如果a==b.那么肯定是先手获胜。一步就可以减为0,b

如果a%b==0.就是a是b的倍数,那么也是先手获胜。

如果a>=2*b. 那么走这一步的人肯定知道a%b,b是必胜态还是必败态。如果是必败态,先手将a,b变成a%b,b,那么先手肯定赢。如果是必胜态,先手将a,b变成a%b+b,b.那么对手只有将这两个数变成a%b,b,先手获胜。

如果是b

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,m;

int main()
{
    while(~scanf("%d %d",&n,&m)&&n+m)
    {
        int flag=0;//用flag记录步数,应为stan先手,所以奇数为stan,偶数为Ollie 
        while(1)
        {
            if(n<m)
            {
                int temp=n;
                n=m;
                m=temp;
            }
            //n%m==0 此时只需一步就可以将其中一个数变为0,flag++,然后游戏结束break. 
            if(n%m==0) {flag++;break;}
            else
            {
                //此时走这一步的人知道(n%m,m)和(n%m+m,m)那一个位必胜局势或必败局势,只需要走完这
                //一步使得局势变为必败局势 ,则后手必败,此时只需flag++即可,因为此时胜负已定,后面
                //的步数也一定会是偶数步,不会影响奇偶判断 
                if(n/m>=2) {flag++;break;}
            }
            //上述两种情况都不存在,flag++,n=n-m; 
            n=n-m;
            flag++;
        }
        printf("%s\n",flag%2==0?"Ollie wins":"Stan wins");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值