【HDU 2147】kiki's game(博弈 PN图)

Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can’t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input

Input contains multiple test cases. Each line contains two integer n, m (0

Output

If kiki wins the game printf “Wonderful!”, else “What a pity!”.

Sample Input

5 3
5 4
6 6
0 0

Sample Output

What a pity!
Wonderful!
Wonderful!

题目大意

给你一个n*m的图,右上角(即点(1,m))有一个硬币,每次从右上角出发,每次可以移动硬币到左边,下边和左下边的格子中,kiki先手,如果某一方无法移动硬币即判为输。

思路

可以用PN图找规律,没用过PN图的可以先看下面这个PPT:
http://wenku.baidu.com/link?url=jKRu1xEziAGvIZ608K4JaDjJZRsPIUPJYLj4SRGdrg0HWQPyTcgzcjow7dIx2JKOALAND_kIzLDNFTT9soVP9I4liACwaLIujg2z5CJbB0y

这里写图片描述

可以从PN图中找到规律,当n和m中有一个为偶数时,先手(kiki)必胜。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,m;

int main()
{
    while(~scanf("%d %d",&n,&m)&&m+n)
    {
        printf("%s\n",(n%2==0||m%2==0)?"Wonderful!":"What a pity!");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值