【HDU 1016】Prime Ring Problem(DFS)

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

这里写图片描述

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题目大意

给你一个n,问你能否将1~n中的各个数字拼成一个素数环,要求相邻两个元素之间相加为素数。

思路

对于每一种情况都去跑一边DFS,记录步数,看最后步数和N是否相等,相等即为一种可行情况。

代码

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

int CaseTime;
int Number;
int direction[21];
int DoneNumber;
int num[21];
int chess[21];


bool IsLeagal( int tmp )
{
    if( tmp == 3 || tmp == 5 || tmp == 7 || tmp == 11 || tmp == 13 || tmp == 17 || tmp == 19 )
        return true;
    if( tmp == 23 || tmp == 31 || tmp == 37 )
        return true;
    return false;
}

void solve(int startnum,int overnum,int settime)
{
    if(overnum == Number)
    {
        for(int i=0;i<Number;i++)
        {
            if(i==0) printf("%d",num[i]);
            else printf(" %d",num[i]);
        }
        printf("\n");
        return ;
    }
    int i;
    for(i=1;i<=Number;i++)
    {
        if(overnum==Number-1)
        {
            if(IsLeagal(startnum+direction[i])&&IsLeagal(direction[i]+1)&&!chess[i])
            {
                chess[i]=1;
                num[settime] = i;
                solve(i,overnum+1,settime+1);
                chess[i]=0;
            }
        }
        else if(IsLeagal(startnum+direction[i])&&!chess[i])
        {
                chess[i]=1;
                num[settime] = i;
                solve(i,overnum+1,settime+1);
                chess[i]=0;
        }
    }
}

int main()
{
    for(int i=1;i<=20;i++)
        direction[i]=i;
    CaseTime=0;
    while(scanf("%d",&Number)!=EOF)
    {
        memset(chess,0,sizeof(chess));
        chess[1]=1;
        num[0]=1;
        printf("Case %d:\n",++CaseTime);
        solve(1,1,1);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值