【HDU 1195】Open the Lock(BFS)

Description

Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.
Each time, you can add or minus 1 to any digit. When add 1 to ‘9’, the digit will change to be ‘1’ and when minus 1 to ‘1’, the digit will change to be ‘9’. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.

Input

The input file begins with an integer T, indicating the number of test cases.

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.

Output

For each test case, print the minimal steps in one line.

Sample Input

2
1234
2144

1111
9999

Sample Output

2
4

题目大意

给你一串数字为密码,再给你一串数字,每次操作可以将这串数字中的某个数字+1或者-1或者和相邻的元素交换,问你最少需要几步操作可以将这串数字变成和密码一样的数字串。

思路

对+1,-1和交换进行bfs,对于每一个状态,定义vis[x][y][z][w]来表示当前数字串是否已经访问过。bfs保证第一个到达终点状态的花费最少。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>

using namespace std;
const int maxn=10;

int vis[maxn][maxn][maxn][maxn];

struct proc
{
    int num[4];
    int step;
}pas,inp;

int bfs()
{
    queue<proc> q;
    proc vw,vn;
    vw=pas;
    vw.step=0;
    vis[vw.num[0]][vw.num[1]][vw.num[2]][vw.num[3]]=1;
    q.push(vw);
    while(!q.empty())
    {
        vw=q.front();
        q.pop();
        if(vw.num[0]==inp.num[0]&&vw.num[1]==inp.num[1]&&vw.num[2]==inp.num[2]&&vw.num[3]==inp.num[3])
        {
            return vw.step;
        }
        for(int i=0;i<4;i++)//+
        {
            vn=vw;
            vn.num[i]++;
            if(vn.num[i]==10) vn.num[i]=1;
            if(!vis[vn.num[0]][vn.num[1]][vn.num[2]][vn.num[3]])
            {
                vis[vn.num[0]][vn.num[1]][vn.num[2]][vn.num[3]]=1;
                vn.step=vw.step+1;
                q.push(vn);
            }
        }
        for(int i=0;i<4;i++)//-
        {
            vn=vw;
            vn.num[i]--;
            if(vn.num[i]==0) vn.num[i]=9;
            if(!vis[vn.num[0]][vn.num[1]][vn.num[2]][vn.num[3]])
            {
                vis[vn.num[0]][vn.num[1]][vn.num[2]][vn.num[3]]=1;
                vn.step=vw.step+1;
                q.push(vn);
            }
        }
        for(int i=0;i<3;i++)//exchange
        {
            vn=vw;
            vn.num[i]=vw.num[i+1];
            vn.num[i+1]=vw.num[i];
            if(!vis[vn.num[0]][vn.num[1]][vn.num[2]][vn.num[3]])
            {
                vis[vn.num[0]][vn.num[1]][vn.num[2]][vn.num[3]]=1;
                vn.step=vw.step+1;
                q.push(vn);
            }
        }

    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        string s;
        cin>>s;
        for(int i=0;i<4;i++)
        {
            pas.num[i]=s[i]-'0';
        }
        cin>>s;
        for(int i=0;i<4;i++)
        {
            inp.num[i]=s[i]-'0';
        }
        int ans=bfs();
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值