hdu5832 A water problem

A water problem


Time Limit: 5000/2500 MS(Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 5814    Accepted Submission(s): 1238


Problem Description

Two planets named Haha andXixi in the universe and they were created with the universe beginning.

There is  73  days in Xixi a year and  137  days in Haha a year. 

Now you know the days  N  after Big Bang, you need to answer whether it is the first day ina year about the two planets.

 

 

Input

There are several testcases(about  5  huge test cases).

For each test, we have a line with an only integer  N (0≤N ) ,the length of  N  is up to  10000000 .

 

 

Output

For the i-th test case,output Case #i: , then output "YES" or "NO" for the answer.

 

 

Sample Input

10001
0
333

 

 

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

 

 

 

 

 

 

题解:

求是否是两个年份的第一天,只要是他们的公倍数就可以了,不过N的长度是10000000,所以要用到大数求余

 

 

代码:

#include<iostream>  
#include<cstdio>  
#include<cstring>  
using namespace std;  
char s[10000000+5],result[1000];  


int main()  
{  
    long long mod,divis;  
    int  n,i,k,flag,len;  
    char c;  
    int kase = 0;
    
    while(scanf("%s",s)!=EOF)
	{
		printf("Case #%d: ",++kase);
		
		len=strlen(s);  
		
		int n= 10001;
      
        mod=0;  
        
        for(i=0; i<len; i++)  
        {  
            mod=mod*10+s[i]-'0';            
            mod=mod%n;                     
        }  
        
        if(mod==0)
        {
        	printf("YES\n");
        }
        else
        {
        	printf("NO\n");
        }  
		
	}	
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值