HDU-1690 Bus System(最短路[Dijkstra])

21 篇文章 0 订阅

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
  
  
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
  
  
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.


这道题和hdu1596 find the safest road类似,做法也差不多,只不过需要自己求边的权值。又是1次AC,虽然写的慢,但想的比较全面。

做完这些比较简单的最短路题后,已经基本熟悉Dijkstra的邻接表做法



#include <cstdio>
#include <cmath>
#include <cstring>

using namespace std;

const long long INF=0x3f3f3f3f3f3f3f3fLL;
int dists[6]={0,0,0,0,0,0x7fffffff},coord[105];
long long cst[105][105],w[105][105],costs[6]={0,0,0,0,0,INF};//本来想只将cst定义为long long,但INF定义的是long long为了减少错误,便将需要用到的都改为long long
int n,m,s,e;
bool vis[105],cal[105][105];

void Dijkstra() {
    int i,j,u;
    long long tmp;
    memset(vis,false,sizeof(vis));
    cst[s][s]=0;
    for(i=1;i<=n;++i) {
        tmp=INF;
        for(j=1;j<=n;++j)
            if(!vis[j]&&cst[s][j]<tmp)
                tmp=cst[s][u=j];
        if(tmp==INF)
            return ;
        vis[u]=cal[s][u]=cal[u][s]=true;
        for(j=1;j<=n;++j)
            if(!vis[j]&&(tmp=cst[s][u]+w[u][j])<cst[s][j])
                cst[s][j]=cst[j][s]=tmp;
    }
}

int main()
{
    int i,j,k,T,kase=0;
    scanf("%d",&T);
    while(kase<T) {
        printf("Case %d:\n",++kase);
        for(i=1;i<=4;++i)
            scanf("%d",dists+i);
        for(i=1;i<=4;++i)
            scanf("%I64d",costs+i);
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;++i) {
            scanf("%d",coord+i);
            for(j=1;j<i;++j) {
                s=abs(coord[j]-coord[i]);
                for(k=5;k;--k)
                    if(dists[k-1]<s&&s<=dists[k]) {
                        w[i][j]=w[j][i]=costs[k];//计算边的权值
                        break;
                    }
                cal[i][j]=cal[j][i]=false;
                cst[i][j]=cst[j][i]=INF;//初始化
            }
            w[i][i]=INF;
            cal[i][i]=true;
            cst[i][i]=INF;
        }
        while(m--) {
            scanf("%d%d",&s,&e);
            if(!cal[s][e])
                Dijkstra();
            if(cst[s][e]==INF)
                printf("Station %d and station %d are not attainable.\n",s,e);
            else
                printf("The minimum cost between station %d and station %d is %I64d.\n",s,e,cst[s][e]);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值