HDU-5585 Numbers(数学)

65 篇文章 0 订阅
http://acm.hdu.edu.cn/showproblem.php?pid=5585

Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains a integer N. (0<N<1030)
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
2 3 5 7
 

Sample Output
  
  
YES YES YES NO

题目大意:如果n能被2,3,5中的一个数整除就输出YES,否则输出NO


我才不会说我被吓怕了,直接高精度模版过的...


仔细想想,2,3,5都很特殊

只要末尾为偶数就能被2整除

只要末尾为0或5就能被5整除

只要所有位的数字之和能被3整除,则该数就能被3整除


#include <cstdio>
#include <cstring>

using namespace std;

int len,sum,i;
char s[31];

int main() {
	while(1==scanf("%s",s)) {
        len=strlen(s);
        sum=s[len-1]-'0';
        if(sum%2==0||sum%5==0)
            printf("YES\n");
        else {
            for(i=len-2;i>=0;--i)
                sum+=s[i]-'0';
            printf("%s\n",sum%3==0?"YES":"NO");
        }
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值