HDU-4569 Special equations (数学)

65 篇文章 0 订阅

Special equations

http://acm.hdu.edu.cn/showproblem.php?pid=4569

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Special Judge

Problem Description
  Let f(x) = a nx n +...+ a 1x +a 0, in which a i (0 <= i <= n) are all known integers. We call f(x) 0 (mod m) congruence equation. If m is a composite, we can factor m into powers of primes and solve every such single equation after which we merge them using the Chinese Reminder Theorem. In this problem, you are asked to solve a much simpler version of such equations, with m to be prime's square.
 

Input
  The first line is the number of equations T, T<=50.
  Then comes T lines, each line starts with an integer deg (1<=deg<=4), meaning that f(x)'s degree is deg. Then follows deg integers, representing a n to a 0 (0 < abs(a n) <= 100; abs(a i) <= 10000 when deg >= 3, otherwise abs(a i) <= 100000000, i<n). The last integer is prime pri (pri<=10000). 
  Remember, your task is to solve f(x) 0 (mod pri*pri)
 

Output
  For each equation f(x) 0 (mod pri*pri), first output the case number, then output anyone of x if there are many x fitting the equation, else output "No solution!"
 

Sample Input
  
  
4 2 1 1 -5 7 1 5 -2995 9929 2 1 -96255532 8930 9811 4 14 5458 7754 4946 -2210 9601
 

Sample Output
  
  
Case #1: No solution! Case #2: 599 Case #3: 96255626 Case #4: No solution!

看到Special Judge和中国剩余定理就有点怕,直接题解了...发现这对数学好的人来说又是一道简单题

题目只求任意一个x使f(x)%(pri*pri)=0,满足这个的必要条件是f(x)%(pri)=0,所以先在0~pri中枚举x,若找不到符合条件的则无解,找到则令x+=pri再次在x~pri*pri中枚举x,若找不到符合条件的则无解,找到则为答案。

#include <cstdio>
#include <algorithm>

using namespace std;

long long n,a[5],pri,ppri,x;

long long f(long long num) {
    long long fx=0,t=1;
    for(int i=0;i<=n;++i) {
        fx+=a[i]*t;
        t*=num;
    }
    return fx;
}

int main() {
    int T,kase=0;
    scanf("%d",&T);
    while(kase<T) {
        scanf("%I64d",&n);
        for(int i=n;i>=0;--i)
            scanf("%I64d",a+i);
        scanf("%I64d",&pri);
        printf("Case #%d: ",++kase);
        x=0;
        while(x<pri) {
            if(f(x)%pri==0)
                break;
            ++x;
        }
        if(x==pri)
            printf("No solution!\n");
        else {
            ppri=pri*pri;
            while(x<ppri) {
                if(f(x)%ppri==0)
                    break;
                x+=pri;
            }
            if(x>=ppri)
                printf("No solution!\n");
            else
                printf("%I64d\n",x);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值