HDU-4961 Boring Sum (模拟)

16 篇文章 0 订阅

Boring Sum

http://acm.hdu.edu.cn/showproblem.php?pid=4961

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)


Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.

Given an integer sequence, your task is to calculate its boring sum.
 

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).

The input is terminated by n = 0.
 

Output
Output the answer in a line.
 

Sample Input
  
  
5 1 4 2 3 9 0
 

Sample Output
  
  
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.

又是无限接近正解而没有写出来,原本想着维护一个[1,i)中是a[i]点倍数点下标点最值,但是两个最值都要维护,就不会了。。。


先正着扫一遍,维护[1,i)中是a[i]点倍数点下标点最大值,并及时更新b[i];再倒着扫一遍,维护(i,n]中是a[i]点倍数点下标点最小值,并及时更新c[i]

最后相乘得出答案

#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;

const int MAXN=100005;

int n,f,g;
int a[MAXN],b[MAXN],c[MAXN],indx[MAXN];
long long ans;
vector<int> factor[MAXN];//factor[i]表示i点因子的表

int main() {
    for(int j=1;j<=MAXN;++j)
        for(int i=j;i<=MAXN;i+=j)
            factor[i].push_back(j);

    while(scanf("%d",&n),n!=0) {
        memset(indx,0,sizeof(indx));
        for(int i=1;i<=n;++i) {//indx[x]表示[1,i)中是a[i]的倍数的最大下标
            scanf("%d",a+i);
            f=indx[a[i]]==0?i:indx[a[i]];
            b[i]=a[f];
            for(int j=0;j<factor[a[i]].size();++j)
                indx[factor[a[i]][j]]=max(indx[factor[a[i]][j]],i);
        }
        memset(indx,0x3f,sizeof(indx));
        for(int i=n;i>0;--i) {//indx[x]表示(i,n]中是a[i]的倍数的最小下标
            g=indx[a[i]]==0x3f3f3f3f?i:indx[a[i]];
            c[i]=a[g];
            for(int j=0;j<factor[a[i]].size();++j)
                indx[factor[a[i]][j]]=min(indx[factor[a[i]][j]],i);
        }
        ans=0;
        for(int i=1;i<=n;++i)
            ans+=(long long)b[i]*c[i];
        printf("%I64d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值