HDU-4336 Card Collector(状压概率DP||容斥原理)

77 篇文章 0 订阅

Card Collector

http://acm.hdu.edu.cn/showproblem.php?pid=4336

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Special Judge

Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
  
  
1 0.1 2 0.1 0.4
 

Sample Output
  
  
10.000 10.500

题目大意:共有n张卡,每次一包方便面,可能有p[i]概率获得第i张卡,也有可能没有卡获得,求拿到全部n张卡需要买的方便面的期望?


解法一:概率DP

感觉做了这么多概率dp,还是离熟悉比较远

合集里看到的,结果一眼就看到是用状态压缩做,然后状态都出来了,转移就没什么难度了...

设dp[i]表示当前取到了i的二进制中位的为1的卡时,离达到目标状态还需要购买方便面的期望,初始状态:dp[(1<<n)-1]=0;

则dp[i]可以转化为:

①:下一袋方便面没有卡,或j卡已有,即:(∑p[j]+pp)*(dp[i]+1);

②:下一袋方面面存在j卡,且当前没有,即:(∑p[j]*(dp[i|(1<<j)]+1);

状态转移方程为:dp[i]=(∑p[j]+pp)*(dp[i]+1)+∑p[j]*(dp[i|(1<<j)]+1);

化简后得:dp[i]=(∑p[j]*dp[i|(1<<j)]+1)/(1-p[j]-pp);

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAXN=(1<<20)+5;

int n,mx;
double p[25],pp,tmp;//pp表示没有卡的概率
double dp[MAXN];//dp[i]表示当前取到了i的二进制中位的为1的卡时,离达到目标状态还需要购买方便面的期望

int main() {
    while(1==scanf("%d",&n)) {
        mx=1<<n;
        pp=1;
        for(int i=0;i<n;++i) {
            scanf("%lf",p+i);
            pp-=p[i];
        }
        dp[mx-1]=0;
        for(int i=mx-2;i>=0;--i) {
            dp[i]=1;
            tmp=pp;
            for(int j=0;j<n;++j) {
                if((i&(1<<j))==0) {//由仅比i状态多1张卡的状态转移
                    dp[i]+=p[j]*dp[i|(1<<j)];
                }
                else {//tmp表示再买一包时,里面没卡以及卡是已在i状态有时的概率和
                    tmp+=p[j];
                }
            }
            dp[i]/=1-tmp;
        }
        printf("%.4lf\n",dp[0]);
    }
    return 0;
}

解法二:容斥原理


即: 含有奇数个事件的概率为加,含有偶数个事件的概率为减

然后统计1~(1<<n)-1的每个状态的期望即可
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAXN=(1<<20)+5;

int n,mx,cnt;
double p[25],tmp,ans;//tmp表示某一状态下

int main() {
    while(1==scanf("%d",&n)) {
        mx=1<<n;
        ans=0;
        for(int i=0;i<n;++i) {
            scanf("%lf",p+i);
        }
        for(int i=1;i<mx;++i) {
            cnt=0;
            tmp=0;
            for(int j=0;j<n;++j) {
                if((i&(1<<j))!=0) {//统计达到i状态位为1的概率和
                    tmp+=p[j];
                    ++cnt;
                }
            }
            if((cnt&1)==0) {//偶数张卡
                ans-=1.0/tmp;
            }
            else {//奇数张卡
                ans+=1.0/tmp;
            }
        }
        printf("%.4lf\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值