HDU-3555 Bomb (数位DP)

77 篇文章 0 订阅

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

题目大意:统计1~n中含有连续49的数字的个数?


数位DP入门题

设dp[i][0]表示长度为i,不含49的数字个数;dp[i][1]表示长度为i,不含49且最高位为9的数字个数;dp[i][2]表示长度为i,含有49的数字个数

不是很明白为什么第二维状态要这样取...

#include <cstdio>

using namespace std;

int num[25],len;
long long n,ans;
long long dp[25][3];//dp[i][0]表示长度为i,不含49的数字个数;dp[i][1]表示长度为i,不含49且最高位为9的数字个数;dp[i][2]表示长度为i,含有49的数字个数

void Init() {
    dp[0][0]=1;
    dp[0][1]=dp[0][2]=0;
    for(int i=1;i<=20;++i) {
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1];//长度为i-1且不含49的,最高位加上0~9,共10种情况;但若最高位加上4,则要减去次高位为9的情况dp[i-1][1]
        dp[i][1]=dp[i-1][0];//长度i-1且不含49的,最高位加上9
        dp[i][2]=dp[i-1][2]*10+dp[i-1][1];//长度i-1且含49的,最高位加上0~9;长度i-1且最高位为9的,最高位加上4
    }
}

long long getCnt(long long x) {//得到区间[1,x]中满足题意的数字个数
    ++x;
    ans=len=0;
    while(x>0) {
        num[++len]=x%10;
        x/=10;
    }
    num[len+1]=-1;
    bool flag=false;//判断高位是否出现过49,true表示高位出现过
    for(int i=len;i>=1;--i) {//从最高位开始枚举
        ans+=dp[i-1][2]*num[i];//当前位取0~(num[i]-1),后面i-1位数为含49的数

        if(flag) {//如果高位已经出现过49
            ans+=dp[i-1][0]*num[i];//当前位去0~(num[i]-1),后面i-1位数为不含49的数【最开始已经加上了含49的数,所以不必再加】
        }
        if(!flag&&num[i]>4) {//如果高位未出现过49,且当前位为大于4
            ans+=dp[i-1][1];
        }
        if(num[i+1]==4&&num[i]==9) {//若该位与上一位能组成49
            flag=true;
        }
    }
    return ans;
}

int main() {
    Init();
    int T;
    scanf("%d",&T);
    while(T-->0) {
        scanf("%I64d",&n);
        printf("%I64d\n",getCnt(n));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值