【POJ1979】

Red and Black
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6

13

最多能走多少格?

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
#include<cstdio>
#include<cstring>
int x,y,n,m,ans;
int dx[4]={0,1,-1,0};
int dy[4]={1,0,0,-1};
char map[300][300];
bool vis[300][300];
void f(int x,int y)
{
	for(int i=0;i<4;i++)
	{
		if(map[x+dx[i]][y+dy[i]]=='.'&&vis[x+dx[i]][y+dy[i]]==false&&x+dx[i]>=0&&y+dy[i]>=0&&x+dx[i]<m&&y+dy[i]<n)//判断是否符合条件
		{
			vis[x+dx[i]][y+dy[i]]=true;//记录为走过的为true
			ans++;//记录走的格数
			f(x+dx[i],y+dy[i]);//以下一格为目标继续判断
		}
	}
}
int main()
{
	while(scanf("%d%d",&n,&m)&&(n||m))
	{
		
		memset(vis,false,sizeof(vis));
		for(int i=0;i<m;i++)
		{
			getchar();
			for(int j=0;j<n;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@')
				{
					x=i,y=j;
					vis[i][j]=true;
				}
			}
		}
		ans=0;
		f(x,y);
		printf("%d\n",ans+1);//加上最开始的一格
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值