【POJ 1611】The Suspects并查集

 The Suspects
Time Limit:1000MS     Memory Limit:20000KB     64bit IO Format:%lld & %llu

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
//0是公认的怀疑对象,所以每个测试数据至少有一个怀疑对象,然后看有没有和0是一组的,如果有那么这一组都是怀疑对象
如果这些成员还在其他组,那其他全组也是怀疑对象,意思是一组中只要有一个怀疑对象,那么该组成员都会成为怀疑对象 
基础并查集应用,将所有同属一大组的同学合并。最后找出0号同学所在组的人数,即为嫌疑人数。
ac
#include<stdio.h>
int f[30000];
int rand[30000];//秩 
int num[30000];//记录集合元素个数 
int find(int x)//寻根 
{
	if(x==f[x])
   return x;
   else
   {
   	f[x]=find(f[x]);
   	return f[x];
   }
}
void unio(int a,int b)//合并集合 
{
	int x=find(a);
	int y=find(b);
	if(x==y) return ;
	if(rand[x]>rand[y])//按秩合并 
	{
		f[y]=x;
	num[x]+=num[y];
	}
	else
	{
		f[x]=y;
		if(rand[x]==rand[y])
			rand[y]++;
		num[y]+=num[x];	
	}
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m),(n||m)) 
	{
	for(int i=0;i<n;i++)//初始化 
	{
		f[i]=i;
		rand[i]=0;
		num[i]=1;
	}
	int k,first,next;
	for(int i=0;i<m;i++)
	{
		scanf("%d%d",&k,&first);
		for(int j=1;j<k;j++)
		{
			scanf("%d",&next);
			unio(first,next);
			first=next;
		}
	}
	printf("%d\n",num[find(0)]);		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值