【杭电1856】More is better找最大集合

More is better
Time Limit:1000MS     Memory Limit:102400KB     64bit IO Format:%I64d & %I64u

Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2
找出最大集合,有直接或间接朋友关系的为一个集合
#include<cstdio>
 #include<algorithm>
 using namespace std; 
  int n,a,b,max0,max1,i,num[10000000],f[10000000];
  int find(int a)
  {
      if(a==f[a])
         return a;
     else
         return f[a]=find(f[a]);
 }
 void f1(int x,int y)
 {
     int nx,ny;
     nx=find(x);
     ny=find(y);
     if(nx!= ny) 
     {  
         	f[ny]=nx;
         num[nx]+=num[ny];
		 }		 	    
 }
 int main()
 {
     while(~scanf("%d",&n))
     {
         for(i = 1 ; i <= 1e7 ; i++)
         {
             f[i]=i;
            
             num[i]=1;        
         }
         if(n == 0)
         {
             printf("1\n");
             continue;
         }
         max0=0;
         for(i = 0 ; i < n ; i++)
         {
             scanf("%d %d",&a,&b);
             max0=max(max0,max(a,b));       
             f1(a,b);
         }
         max1=0;
         for(i = 1 ; i <= max0 ; i++)                                 
                 max1=max(max1,num[i]);        
         printf("%d\n",max1);
     }
  } 

下面代码为啥加上按秩合并就compilation error了╮(╯_╰)╭
#include<cstdio>
 #include<algorithm>
 using namespace std; 
  int n,a,b,max0,max1,i,num[10000000],f[10000000],rank[100000000];
  int find(int a)
  {
      if(a==f[a])
         return a;
     else
         return f[a]=find(f[a]);
 }
 void f1(int x,int y)
 {
     int nx,ny;
     nx=find(x);
     ny=find(y);
     if(nx== ny) return;
     if(rank[nx]>rank[ny])
     {  
         	f[ny]=nx;
         num[nx]+=num[ny];
		 }
		 else
		 {
		 	f[nx]=ny;
		 	if(rank[nx]=rank[ny])
		 	rank[y]++;
		 	num[ny]+=num[nx];	
			 
						  }		 	    
 }
 int main()
 {
     while(~scanf("%d",&n))
     {
         for(i = 1 ; i <= 1e7 ; i++)
         {
             f[i]=i;
            rank[i]=0;
             num[i]=1;        
         }
         if(n == 0)
         {
             printf("1\n");
             continue;
         }
         max0=0;
         for(i = 0 ; i < n ; i++)
         {
             scanf("%d %d",&a,&b);
             max0=max(max0,max(a,b));       
             f1(a,b);
         }
         max1=0;
         for(i = 1 ; i <= max0 ; i++)                                 
                 max1=max(max1,num[i]);        
         printf("%d\n",max1);
     }
  } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值