【杭电1387】Team Queue 嵌套队列

Team Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2014    Accepted Submission(s): 699


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

 

Input
The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

 

Output
For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.
 

Sample Input
  
  
2 3 101 102 103 3 201 202 203 ENQUEUE 101 ENQUEUE 201 ENQUEUE 102 ENQUEUE 202 ENQUEUE 103 ENQUEUE 203 DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 2 5 259001 259002 259003 259004 259005 6 260001 260002 260003 260004 260005 260006 ENQUEUE 259001 ENQUEUE 260001 ENQUEUE 259002 ENQUEUE 259003 ENQUEUE 259004 ENQUEUE 259005 DEQUEUE DEQUEUE ENQUEUE 260002 ENQUEUE 260003 DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 0
 

Sample Output
  
  
Scenario #1 101 102 103 201 202 203 Scenario #2 259001 259002 259003 259004 259005 260001
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1509   1381   1103   1341   1392  
首先有两种队列,一个存入队列号p,其他的存入对应一组数的数值q
给出多组数列,将他们依次存入队列,输入时:当队列里还没有元素时,队列号i存入p,如果已经有数,将其他的数继续存入队列q[i]
输出时:如果该队列已经没有元素,则将p里对应的序列号删除
如案例一:
有两个数组:0   101 102 103
                     1    201 202 203   team[m]记录m所在的序列号
进队列时 q[0]刚开始为空,序列号0进入p ,如果输入序列1中的数,1进入p;
p  0 1
q[0]   101 102 103
q[1]   201 202 203
code:
 
#include<stdio.h>
#include<string.h>
#include<map>
#include<algorithm>
#include<queue>
using namespace std;
int main()
{
	int t,n,m,T,k=1;
	char s[20];
	while(scanf("%d",&T),T)
	{
		map<int,int>team;
		queue<int>q[1100],p;
		for(int i=0;i<T;i++)
		{
			scanf("%d",&n);
			for(int j=0;j<n;j++)
			{
				scanf("%d",&t);
				team[t]=i;//记录队列号 
			}
		}
		printf("Scenario #%d\n",k++);
		while(1)
		{
			scanf("%s",s);
			if(s[0]=='S') break;
			else if(s[0]=='E')//输入 
			{
				scanf("%d",&m);
				t=team[m];
				if(q[t].empty())//所在队列为空 
				p.push(t);//队列号进队 
				q[t].push(m);
			}
			else{
				t=p.front();//取出最前面的队列号 
				printf("%d\n",q[t].front());//输出该队列头元素 
				q[t].pop();//删除 
				if(q[t].empty())
				p.pop();//如果该队列元素已经全部输出,删除最前面的队列号 
			} 
		 } 
		 printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值