HDU 1024 Max Sum Plus Plus(基础dp)

[kuangbin带你飞]专题十二 基础DP1;

网址:https://cn.vjudge.net/contest/68966#problem/A

                            A - Max Sum Plus Plus

  HDU - 1024 

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S  1, S  2, S  3, S  4 ... S  x, ... S  n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S  x ≤ 32767). We define a function sum(i, j) = S  i + ... + S  j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i  1, j  1) + sum(i  2, j  2) + sum(i  3, j  3) + ... + sum(i  m, j  m) maximal (i  x ≤ i y ≤ j  x or i  x ≤ j  y ≤ j  x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i  x, j  x)(1 ≤ x ≤ m) instead. ^_^ 
Input
Each test case will begin with two integers m and n, followed by n integers S  1, S 2, S  3 ... S  n
Process to the end of file. 
Output
Output the maximal summation described above in one line. 
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8


        
  
Hint
Huge input, scanf and dynamic programming is recommended.

        
 


题意:最大和连续子序列增强版。给你一段序列,让你从中取出M段(不能重叠),使取出的段的和最大。

分析:简单思考后可得出一个2D/1D的做法:

用dp[i][j]表示前i个数(且第i个数被取出)取出j段得到的最大值,那么状态转移方程为:

                             dp[i][j]=max(dp[i-1][j]+a[i],dp[k][j-1]+a[i])  j-1<=k<=i-1


这个状态转移方程表达了两种不同的选择:第一个就是第i个连在第i-1个所在的段的后面,第二个就是第i个为新的一段的第一个数字(遍历出一个k使dp[k][j-1]最大)。

但是这个想法时间和空间都超范围了。首先想空间,分段只和j-1段有关,可用滚动数组优化。再想时间,遍历k的过程实际上在遍历i的过程中就能判断出来。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
#include<iostream>
#include<map>
#include<math.h>
using namespace std;
#define MAXN 1000009

int main()
{
    int d,n;
    long long num[MAXN];
    long long dp[MAXN];
    long long tmax[MAXN];
    while(scanf("%d%d",&d,&n) != EOF){
        for(int i = 0;i <= n;i++){
            dp[i] = 0;
            tmax[i] = 0;
        }
        for(int i = 1;i <= n;i++){
            scanf("%lld",&num[i]);
        }
        long long temp = 0;
        int tempj = 0;
        for(int j = 1;j <= d;j++){
           temp = -999999999999;
           for(int i = j;i <= n;i++){
                dp[i] = max(dp[i-1],tmax[i-1])+num[i];//num[i]可以提取出来
                tmax[i-1] = temp;//前一段不用滚动,后一段用temp取的值代替
                temp = max(temp,dp[i]);//取最大的dp[k][j-1]
           }
        }

        printf("%lld\n",temp);
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值