2016ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学) 1003 Recursive sequence(题解)

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 98    Accepted Submission(s): 46


Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231 as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
  
  
2 3 1 2 4 1 10
 

Sample Output
  
  
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

题意:f(n) = 2*f(n-2)+f(n-1)+n^4,给定f(1),f(2)求f(n)。

矩阵快速幂,难点在于n^4如何构造于矩阵之中。因为(n+1)^4 =  n^4+4*n^3+6*n^2+4*n+1,所以可将n^4由n-1表示出来。

因此矩阵可构造为 :

1 2 1 4 6 4 1        f(n-1)             f(n)

1 0 0 0 0 0 0        f(n-2)             f(n-1)

0 0 1 4 6 4 1       (n-1)^4           n ^  4

0 0 0 1 3 3 1  *    (n-1)^3   =     n  ^ 3

0 0 0 0 1 2 1       (n-1)^2           n  ^  2

0 0 0 0 0 1 1       (n-1)^1           n  ^  1

0 0 0 0 0 0 1       (n-1)^0           n  ^  0

然后就可以用矩阵快速幂做了。

代码:


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

struct Matrix{
    long long m[7][7];
}ans,base;

long long Base[7][7] = {1,2,1,4,6,4,1,    //base矩阵
                        1,0,0,0,0,0,0,
                        0,0,1,4,6,4,1,
                        0,0,0,1,3,3,1,
                        0,0,0,0,1,2,1,
                        0,0,0,0,0,1,1,
                        0,0,0,0,0,0,1};
long long danwei[10],mod = 2147493647;

Matrix Multi(Matrix a,Matrix b)//矩阵做乘运算
{
    Matrix temp;
    for(int i = 0;i < 7;i++){
        for(int j = 0;j < 7;j++){
            temp.m[i][j] = 0;
            for(int k = 0;k < 7;k++)
                temp.m[i][j] = (temp.m[i][j] + (b.m[i][k] * a.m[k][j])%mod)%mod;
        }
    }
    return temp;
}

long long Fast_mod(long long num,long long a,long long b)//矩阵快速幂
{
    memset(ans.m,0,sizeof(ans));
    ans.m[0][0] = b;   //将给定值输入到初始矩阵
    ans.m[1][0] = a;
    long long gei[7] = {0,0,16,8,4,2,1}; 
    for(int i = 2;i < 7;i++){
        ans.m[i][0] = gei[i];
    }
    
    while(num){ //矩阵快速幂的核心部分
        if(num&1){ // 将num转化为2进制与1&
            ans = Multi(ans,base);
        }
        base = Multi(base,base);
        num >>= 1;
    }

    return ans.m[0][0];
}

int main()
{
    int t;

    scanf("%d",&t);
    while(t--){
        long long N,a,b;
        for(int i = 0;i < 7;i++)
          for(int j = 0;j < 7;j++)
            base.m[i][j] = Base[i][j];

        scanf("%lld%lld%lld",&N,&a,&b);
        if(N >= 3)
            printf("%lld\n",Fast_mod(N-2,a,b));
        else if(N == 2)
            printf("%lld\n",b);
        else
            printf("%lld\n",a);
    }
    return 0;
}


                                            





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值