HDUOJ 1022

HDUOJ 1022 Train Problem I


题目来源

题意简析

原题

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

[Input]
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

[Output]
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.

Sample Input
3 123 321
3 123 312

Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

我的理解:
车站类似成一个栈,列车按给定的顺序存放在栈内,检测是否可以按给定的顺序出栈。

解决办法:模拟出栈
设p1为栈内标记,从0(栈底)开始。设p2为出栈标记,也从0开始。

若当前元素就是出栈元素,则标记下降一个位置,删去当前元素(string类的特性,在erase()操作后会自动前移)。特别的,当标记在栈底时,不下降(否则会溢出),且flag=1,意为下一次要进栈一个元素。如果进栈标记不是0,flag=0且标记下移,意为连续判断出栈,栈内还有元素,尚且不需要进栈。最后出栈标记上升。

若不是出栈元素,进栈一个元素,同时计数进栈次数,以免超出。

直到进栈标记超出进栈表内的元素数量结束循环,可以同时判定两种情况:

  1. 出栈失败,进栈标记到顶也未能出栈,跳出循环
  2. 出栈完毕,进栈表元素数量为0,标记也同时降到0,跳出循环

最后把操作符输出即可。

要点分析

栈的使用
格式控制
某大佬提供的一组不错的测试数据 : 6 123456 215436

参考代码

#include<iostream>
#include<vector>
#include<string>
using namespace std;
int main()
{
	vector<int> p;					//操作符数组,为了输出用
	int len,p1,p2,pl,flag=1;
	string s1,s2;
	while(cin>>len)
	{
		p1=0;p2=0;pl=0;flag=1;		//pl是计数器,计算进栈元素个数 
		p.clear();
		s1.clear();
		s2.clear();					//初始化 
		cin>>s1>>s2; 
		for(;p2<s2.size();)	
		{
			if(pl<len && flag==1)	//是否应该进栈元素
			{
				p.push_back(1);		//1 in
				pl++;
			}
			if(s1[p1]!=s2[p2])
			{
				flag=1;
				p1++;
			}
			else
			{
				flag=0;
				s1.erase(p1,1);
				p2++;
				if(p1==0) flag=1;
				if(p1>0) p1--;
				p.push_back(2);		//2 out
			}
			if(p1>s1.size())		//跳出循环判定
			{
				p.clear();
				p.push_back(0);		//0 No
				break;
			}
		}
		if(p[0]==0)
		{
			cout<<"No."<<endl<<"FINISH"<<endl;
		}
		else
		{
			cout<<"Yes."<<endl;
			for(int j=0;j<p.size();j++)
			{
				if(p[j]==1)cout<<"in"<<endl;
				if(p[j]==2)cout<<"out"<<endl;
			}
			cout<<"FINISH"<<endl;
		}
	}
	return 0;
}

20200702

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值