hdu 1002 解析

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 317305    Accepted Submission(s): 61642


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110


题意:输入T组测试数据,没组测试数据输入两个数。

注意:输入的数据很大。所以不能直接用int来解决。

思路:用数组来处理。代码看起来长,思路其实很简单。

代码如下:

#include<iostream>
#include<string.h>
#include<cstdio>
using namespace std;
int main()
{
    int n,nn=1;
    cin>>n;
    while(n!=0)
    {
        char aa[10000],bb[10000];
        int a[10000],b[10000],c[10000];
        memset(a,0,sizeof(a));//对a数组清零
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        cin>>aa>>bb;//用字符数组才能把数字一位一位的存储
        int la=strlen(aa),lb=strlen(bb);
        for(int i=0;i<la;i++)
            a[i]=aa[la-i-1]-'0';//颠倒了位置,个位数在a【0】的位置了
        for(int i=0;i<lb;i++)
            b[i]=bb[lb-i-1]-'0';
        int l;
        l=max(la,lb);
        int bl=0;
        for(int i=0;i<l;i++)
        {
            int bll=a[i]+b[i]+bl;//bl上次相加是进的位
            if(bll>=10)//要是相加大于10,就进位
            {
                bl=1;
                bll=bll-10;
            }
            else bl=0;
            c[i]=bll;
        }
        if(bl==1)//判断最大位的相加是否会大于10
        {
            c[l]=1;
            cout<<"Case "<<nn<<":"<<endl;
            cout<<aa<<" + "<<bb<<" = ";
            for(int i=l;i>=0;i--)
            cout<<c[i];
            cout<<endl;
        }
        else
        {
            cout<<"Case "<<nn<<":"<<endl;
            cout<<aa<<" + "<<bb<<" = ";
            for(int i=l-1;i>=0;i--)
            cout<<c[i];
             cout<<endl;
        }
        n--;nn++;
        if(n!=0)
            cout<<endl;//每组数据之间要有空行,最后一组不要有!
    }
    return 0;
}


















  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值