POJ-3669 Meteor Shower


Meteor Shower
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20561 Accepted: 5347

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5

Sample Output

5
题意:贝西所在的地方遭受流星雨破坏,每个坐标点的流星开始破坏时间不一样,而且有的地方流星雨不会破坏,在            一个点流星破坏后会连带他的四个方向都破坏,知道流星破坏的点的坐标,以及来临时间,问贝西什么时候会            到达安全地带;

注意:1.当起点(0,0)流星在0时刻开始破坏,贝西就不能走了,输出-1;

           2.开始要将已知的点的流星破坏事件赋给它相邻四个点,同时找到每一个点的最早开始破坏时间;

           3.Map[][]数组的初值要设为-1,因为有些点的开始破坏时间为0;

代码:

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;

struct node
{
	int x;
	int y;
	int step;
};

int Map[350][350],book[350][350],n;
int dir[5][2]={0,0,0,1,1,0,0,-1,-1,0};//包括自身。如果写做4个方向,要改变 

int bfs()
{
	node now,tmp;
	queue<node> Q;
	now.x=0;
	now.y=0;
	now.step=0;
	book[0][0]=1;
	Q.push(now);
	while(!Q.empty())
	{
		now=Q.front();
		Q.pop();
		if(Map[now.x][now.y]==-1)//此地为-1流星不会来,安全,跳出搜索; 
		{
			return now.step;
		}
		for(int i=1;i<=4;i++) //运行时间短; 
		{
			int tx=now.x+dir[i][0];
			int ty=now.y+dir[i][1];
			if( tx>=0 && ty>=0 && ( Map[tx][ty]==-1 || Map[tx][ty]>now.step+1 ) && !book[tx][ty] )//tx,ty只要大于0就好 
			{
				tmp.x=tx;
				tmp.y=ty;
				tmp.step=now.step+1;
				book[tx][ty]=1;
				Q.push(tmp);
			}
		}
	}
	return -1;
}

int main()
{
	while(~scanf("%d",&n))
	{
		memset(Map,-1,sizeof(Map));//可能有些点时间为0 
		memset(book,0,sizeof(book));
		int x,y,z;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d",&x,&y,&z);
			for(int j=0;j<5;j++)
			{
				int tx = x + dir[j][0];
				int ty = y + dir[j][1];
				
				if( tx<0 || ty<0 )
					continue;
				if(Map[tx][ty] == -1)
					Map[tx][ty] = z;
				else
					Map[tx][ty] = min( Map[tx][ty] , z );//该点流星来临的最短时间 
			}
		}
		if(Map[0][0]==0)//在起点就挂了 
		{
			printf("-1\n");
			continue;
		}
		int s=bfs();
		printf("%d\n",s);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值