POJ - 3669 Meteor Shower

Meteor Shower
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20600 Accepted: 5356

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5

Sample Output

5


题意:

        有一片区域,一些陨石分别将在Ti分钟后坠落在其中的一些地方,坠落后,坠落地及其上下左右四个方格被破坏,不能走。求多少分钟后能从(0,0)点走到没有陨石降落的地方。如果起始点一开始被破坏,则输出-1.

题解:

        将map预处理一下,每一格的值代表这个格将在多少分钟后被破坏。然后bfs。


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
#define inf 1<<30
int map[310][310],n;
int ff[4][2]={1,0,0,1,-1,0,0,-1};
bool vis[310][310];
struct node
{
    int y,x,step;
}p;
int bfs()
{
    queue<node> q;
    memset(vis,0,sizeof(vis));
    p.y=p.x=p.step=0;
    if(map[0][0]==0)
        return -1;
    q.push(p);
    vis[0][0]=1;
    while(!q.empty())
    {
        node top=q.front(); q.pop();
        if(map[top.y][top.x]==inf)
            return top.step;
        for(int i=0;i<4;i++)
        {
            int ty=top.y+ff[i][0];
            int tx=top.x+ff[i][1];
            if(ty<0 || tx<0 || vis[ty][tx] || map[ty][tx]<=top.step+1)
                continue;
            vis[ty][tx]=1;
            p.y=ty;
            p.x=tx;
            p.step=top.step+1;
            q.push(p);
        }
    }
    return -1;
}
int main()
{
    while(~scanf("%d",&n))
    {
        int x,y,t;
        for(int i=0;i<305;i++)
            for(int j=0;j<305;j++)
                map[i][j]=inf;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&x,&y,&t);
            map[y][x]=min(map[y][x],t);
            if(x)
                map[y][x-1]=min(map[y][x-1],t);
            if(y)
                map[y-1][x]=min(map[y-1][x],t);
            map[y][x+1]=min(map[y][x+1],t);
            map[y+1][x]=min(map[y+1][x],t);
        }
        printf("%d\n",bfs());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值