POJ-3684 Physics Experiment(弹性碰撞)

Physics Experiment
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2595 Accepted: 913 Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.
1≤ N ≤ 100.
1≤ H ≤ 10000
1≤ R ≤ 100
1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20
题意 在H米高的位置设置了一个圆筒,将球垂直放入(从下向上数第i个球的低端距离地面的高度为H+2R)。
         实验开始时最下面的球开始掉落,此后每一秒又有一个球开始掉落。不计空气阻力,并假设球与球
         或地面的碰撞时弹性碰撞。请求出实验开始T秒钟时每个球低端的高度。假设重力加速度为G=10m/s^2。
思路: 时间T除以单次上升或下降时间( t )取整得(k)为偶数小球在T时刻是下降状态(t1 = T - k*t),为奇数小球在T时刻是上升               状态 (t1 = k*t + t - T  );两个小球之间发生弹性碰撞时速度交换运动状态交换相当于a,b,相互交换,对最终结果没有影响。
    注意单位
代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
#define g 10.0
int N,H,R,T;
double y[10010];//记录球的最终位置
double cacl(int T)
{
    if(T<0)
        return H;//如果球还没有下落返回第一个小球的高度
    double t=sqrt(2*H/g);//一次完整的上升或下落的时间
    int k=(int)(T/t);//有几次完整的上升和下落的时间
    if(k%2==0)//偶数,下降状态
    {
        double d=T-k*t;
        return H-g*d*d/2;
    }
    else//奇数,上升状态
    {
        double d=k*t+t-T;
        return H-g*d*d/2;
    }
}
int main()
{
    int t,cases=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&N,&H,&R,&T);//N个小球,高度H (m)的位置,半径R (cm), 时间T (s);
        for(int i=0;i<N;i++)
            y[i]=cacl(T-i);//第i个小球的位置
        sort(y,y+N);
        printf("Case #%d:\n%.2lf",cases++,y[0]);
        for(int i=1;i<N;i++)
            printf(" %.2lf",y[i]+2*R*i/100.0);
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值