POJ 3684 Physics Experiment【弹性碰撞】

Physics Experiment
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2561 Accepted: 898 Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHR,T.
1≤ N ≤ 100.
1≤ H ≤ 10000
1≤ R ≤ 100
1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20

Point:无视碰撞,直接认为相互穿过继续运动

向下运动时:直接h-1/2gt^2;

向上运动时:可以想象成向下的逆过程h-1/2gt^2(此时的t是完成一个周期运动的剩余时间)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
const int M=1e5+10;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
int i,j,k,n,m;
int h,r,t;
double g=10.0;
double y[M];

double calc(int T)
{
    if(T<0)return h;
    double t=sqrt(2*h/g);
    int k=(int)(T/t);
    double d=T-k*t;
    if(k%2==0)
        return h-g*d*d/2;
    else
        return h-g*(t-d)*(t-d)/2;
}

void solve()
{
    for(int i=0;i<n;i++){
        y[i]=calc(t-i);
    }
    sort(y,y+n);
    for(int i=0;i<n;i++){
        printf("%.2f%c",y[i]+2*r*i/100.0,i+1==n?'\n':' ');
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d%d%d",&n,&h,&r,&t);
        solve();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值