hdu1062-字符串翻转问题 reverse()


Sample Input
  
  
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
  
  
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 
#include <iostream>  
#include<string>
#include <algorithm>
using namespace std; 
int main()  
{
    string str;
    int begin,j,n;
    while (cin>>n)
    {
        getchar();
        while (n--)
        {
            getline(cin,str);
            j = 0;
            begin = 0;
            while(str.find(' ',j)!=string::npos)
            {  
                reverse(str.begin()+j,str.begin()+str.find(' ',j));  //这里的第二个参数不用再加J
                j = str.find(' ',j)+1;
            }
            reverse(str.begin()+j,str.end()); //最后一个单词(没有空格情况)
            cout<<str<<endl;
        }

    }
    return 0;  
}  

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值