杭电acm刷题(3):1062,Text Reverse ...

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

程序思路:

通过空格区分单词,每检测到一个空格更新指针,一个指向头的位置,一个指向尾的位置。

程序:

#include "iostream"
#include "string"
#include "stdio.h"

using namespace std;

int main()
{
    int T;
    string str;
    int len;
    int cnt = 0;
    int start, end;

    cin >> T;
    getchar();

    for (int i = 0;i < T;i++)
    {
        getline(cin, str);
        len = str.size();
        str[len] = ' ';

        start = 0;
        for (int j = 0;j < len + 1;j++)
        {
            if (str[j] == ' ')
            {
                end = j - 1;
                for (int n = end;n >= start;n--)
                    cout << str[n];
                start = j + 1;
                if(j!=len)
                    cout << ' ';
                else
                    cout << endl;
            }
        }
    }

    return 0;
}

补充:

由于每个空格检测一次,所以还需要在接收到的字符串的最后补上一个空格。程序思路不难,很容易搞懂。

转载于:https://www.cnblogs.com/xuhongbin/p/7134164.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值