hdu 5489 Removed Interval (LIS)

Removed Interval

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2198    Accepted Submission(s): 692


 

Problem Description

Given a sequence of numbers A=a1,a2,…,aN, a subsequence b1,b2,…,bk of A is referred as increasing if b1<b2<…<bk. LY has just learned how to find the longest increasing subsequence (LIS).
Now that he has to select L consecutive numbers and remove them from A for some mysterious reasons. He can choose arbitrary starting position of the selected interval so that the length of the LIS of the remaining numbers is maximized. Can you help him with this problem?

 

 

Input

The first line of input contains a number T indicating the number of test cases (T≤100).
For each test case, the first line consists of two numbers N and L as described above (1≤N≤100000,0≤L≤N). The second line consists of N integers indicating the sequence. The absolute value of the numbers is no greater than 109.
The sum of N over all test cases will not exceed 500000.

 

 

Output

For each test case, output a single line consisting of “Case #X: Y”. X is the test case number starting from 1. Y is the maximum length of LIS after removing the interval.

 

 

Sample Input

 

2 5 2 1 2 3 4 5 5 3 5 4 3 2 1

 

 

Sample Output

 

Case #1: 3 Case #2: 1

 

思路:这题如果直接枚举删除的话再找出最长的上升子序列这样时间会超出,然后可以找出要删除的左右两边最大上升子序列之和,以代替枚举要删除的地方之后的最长上升子序列。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define INF 0x3f3f3f
using namespace std;
int a[100005];
int b[100005];
int c[100005];
int dp[100005];
int main()
{
    int T;
    cin>>T;
    int t=1;
    while(T--)
    {
        int m,n;
        cin>>m>>n;
        int i,x;
        for(i=0;i<m;i++)
        {
            scanf("%d",&a[i]);
            b[i]=-a[i];
        }
         memset(c, 0x7f, sizeof(c));
        for(i=m-1;i>=0;i--)
        {
            x=lower_bound(c,c+m,b[i])-c;
            c[x]=b[i];
            dp[i]=x+1;
        }
         memset(c, 0x7f, sizeof(c));
        int zz=0,len=0;
        for(i=n;i<m;i++)
        {
            x=lower_bound(c,c+m,a[i])-c;
            zz=max(zz,x+1+dp[i]-1);
            x=lower_bound(c,c+m,a[i-n])-c;
            c[x]=a[i-n];
            len=max(len,x+1);
        }
        printf("Case #%d: ", t++);
        if(zz>len)len=zz;
        cout<<len<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值