hdu 5831 Rikka with Parenthesis II

Rikka with Parenthesis II

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1616    Accepted Submission(s): 710

 

 

Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence S, and he wants Rikka to choose two different position i,j and swap Si,Sj. 

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?

 

 

Input

The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.

 

 

Output

For each testcase, print "Yes" or "No" in a line.

 

 

Sample Input

 

3 4 ())( 4 ()() 6 )))(((

 

 

Sample Output

Yes Yes No

思路:这题是指交换一次位置后仍然能够配对成功,其实出现一个右括号没有匹配是允许的,连续出现两个右括号没匹配也是可以的,但是三个及三个以上就不可以了,当两个括号时,()时输出“No”的,)(输出“Yes”。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stack>
using namespace std;
char a[111111];
int main()
{
    int T,n;
    int s;
    cin>>T;
    while(T--)
    {
        cin>>n;
        int flag=0;
        int p=0;
        int q=0;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
        {
            if(a[i]=='(')
                p++;
            if(a[i]==')')
                q++;
        }
        if(p!=q)
        {
            cout<<"No"<<endl;
            continue;
        }
        else
        {
            s=0;
            if(p+q==2)
            {
                if(a[0]=='(')
                    flag=1;
            }
            else
            for(int i=0;i<n;i++)
            {
                if(a[i]=='(')
                    s++;
                if(a[i]==')')
                    s--;
                if(s==-3)
                {
                    flag=1;
                    break;
                }
            }
        }
        if(flag==1)
            cout<<"No"<<endl;
        else
            cout<<"Yes"<<endl;
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值