HDU 5831 Rikka with Parenthesis II

题目描述:

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string “” is a correct sequence.
2.If “X” and “Y” are correct sequences, then “XY” (the concatenation of X and Y) is a correct sequence.
3.If “X” is a correct sequence, then “(X)” is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include “”, “()”, “()()()”, “(()())”, and “(((())))”.

Now Yuta has a parentheses sequence S, and he wants Rikka to choose two different position i,j and swap Si,Sj.

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.

Output
For each testcase, print “Yes” or “No” in a line.

Sample Input

3
4
())(
4
()()
6
)))(((

Sample Output

Yes
Yes
No

Hint

For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.

题目分析:

HDU多校第八场1011。
给一个n个字符的串,串由’(‘和’)’组成,其中你必须进行操作,(注意是必须),将这个串中的两个括号互相交换。
进行分析之后可以看到,若左括号和右括号数量不等,输出’No’,或者这个串刚好是’()’,因为必须交换的原因,也是’No’。其它情况,这个括号序列中若有一对不合法,那么交换这一对就可以。若有两对不合法,也就是类似’))((‘类型的,我们可以将其中最左的和最右的交换,就变成’()()’的合法类型了。因此我们可以推断,除去其他情况,这个串中若有一对或者两对不符合括号,输出’Yes’,若大于等于三队,则是’No’。
(采用栈的方法判断括号的匹配情况)

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>

using namespace std;

int T;
stack<int>sta;
int l,r;
int n;
char s[100010];
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        scanf("%s",s);
        if (n==2 && s[0]=='(' && s[1]==')') {printf("No\n");continue;}
        l=0;
        r=0;
        while(!sta.empty()) sta.pop();
        for(int i=0; i<n; i++)
        {
            if (s[i]=='(') sta.push(i);
            else if (s[i]==')')
            {
                if (sta.empty()) r++;
                else sta.pop();
            }
        }
        l=sta.size();
        if (l!=r) {printf("No\n");continue;}
        if (l>2) {printf("No\n");continue;}
        printf("Yes\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值