hdu6055

Regular polygon

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1386    Accepted Submission(s): 529


Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
 

Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
 

Output
For each case, output a number means how many different regular polygon these points can make.
 

Sample Input
      
      
4 0 0 0 1 1 0 1 1 6 0 0 0 1 1 0 1 1 2 0 2 1
 

Sample Output
      
      
1 2
思路:这题其实是找正方形有多少个就可以了,已知两个点就可以枚举其他点是否和给出的一样,最后还要除以8。
代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <cmath>
#include <stdlib.h>
#include <vector>
#include <queue>
#include <stack>
using namespace std;
const int MOD=1e9+7;
vector<int>a1;
vector<int>a2;
int v[100005];
int x[3005],y[3005];
int ma[2055][2055];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i,j;
        memset(ma,0,sizeof(ma));
        for(i=0;i<n;i++)
        {
            scanf("%d %d",&x[i],&y[i]);
            x[i]+=300;
            y[i]+=300;
            ma[x[i]][y[i]]=1;
        }
        long long int sum=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(i==j)continue;
                int a=x[j]-x[i];
                int b=y[j]-y[i];
                if(x[i]-b>=0&&y[i]+a>=0&&x[j]-b>=0&&y[j]+a>=0)
                    if(ma[x[i]-b][y[i]+a]&&ma[x[j]-b][y[j]+a])
                        sum++;
                if(x[i]+b>=0&&y[i]-a>=0&&x[j]+b>=0&&y[j]-a>=0)
                    if(ma[x[i]+b][y[i]-a]&&ma[x[j]+b][y[j]-a])
                        sum++;
            }
        }
        cout<<sum/8<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值