hdu4283

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4234    Accepted Submission(s): 1975


Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 

Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 

Output
  For each test case, output the least summary of unhappiness .
 

Sample Input
  
  
2    5 1 2 3 4 5 5 5 4 3 2 2
 

Sample Output
  
  
Case #1: 20 Case #2: 24
题意:这题就是第k个人出场的愤怒值是(k-1)*Di,可以随便让谁先上场,最后使得愤怒值的总和最小。
思路:一看到这题完全看不出这是一道dp,要不是在dp专题里还以为是排序题,这题主要难在找状态转移方程,就第一组样例来看的话,假设我们已经得到区间1到4的状态值,(长度为5的区间表示为dp[1][5]),倘若1是第三个出场的话那么2和3就要先出场,这样就可以表示成dp[2][3],后面还有两个4和5,就可以先让3*(ans[5]-ans[3]),然后在把4和5当做一个小区间表示为dp[4][5],最后就可以得到状态转移方程dp[i][j]=min(dp[i][j],a[i]*(k-1)+k*(ans[j]-ans[i+k-1])+dp[i+1][i+k-1]+dp[i+k][j])
 
代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int INF=0x3f3f3f;
int dp[105][105];
int main()
{
    int T;
    cin>>T;
    int t=1;
    while(T--)
    {
        int n;
        cin>>n;
        int ans[105];
        int a[105];
        memset(ans,0,sizeof(ans));
        int i,j,k;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            ans[i]=ans[i-1]+a[i];
        }
        for(i=1;i<=n;i++)
        {
            for(j=i+1;j<=n;j++)
            {
                dp[i][j]=INF;
                //要求最小值,那么就初始化为最大值
            }
        }
        for(int e=1;e<n;e++)
        {
            for(i=1;i<=n-e;i++)
            {
                j=e+i;
                for(k=1;k<=j-i+1;k++)
                {
                    dp[i][j]=min(dp[i][j],a[i]*(k-1)+k*(ans[j]-ans[i+k-1])+dp[i+1][i+k-1]+dp[i+k][j]);
                    /*假设i在这个区间里第k个上场,那么i后面的就可以拆成k*(ans[j]-ans[i+k-1])与以i+k到j为
                    区间的最优解的和,其实i前面还有k个,就可以当做以i+1到i+k-1为区间的最优解*/
                }
            }
        }
        printf("Case #%d: %d\n",t++,dp[1][n]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值