hdu4081

Qin Shi Huang's National Road System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9305    Accepted Submission(s): 3306


Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input
  
  
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40
 

Sample Output
  
  
65.00

70.00

题意:秦始皇统一中国之后要在全国修公路连接各个城市,抠门皇帝只想修成最小生成树,一个道士说自己可以不花人力物力修一条路,经过两方妥协,选择max(两个城市人口/(生成树长度-这条路的长度))的路让他变,求这个比值最大值。 

思路:运用prime算法把记录每两个点之间路径上最长的边长,该边就在最小生成树里,则直接减掉,该边不在最小生成树,那么减掉的是构成的环里面除了这条边以外的最大的边。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
const int inf=0x3f3f3f3f;
const int N=1005;
double g[N][N];
double dis[N];
double path[N][N];
bool used[N][N];
int pre[N];
int vis[N];
int n,m,q;
struct node
{
    int x,y,z;
}d[1005];
double  dd(node a,node b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(double)(a.y-b.y)*(a.y-b.y));
}
double prime()
{
    memset(path,0,sizeof(path));
    memset(vis,0,sizeof(vis));
    memset(used,false,sizeof(used));
    int i,j,u=1,v;
    double ans=0;
    for(i=1;i<=n;i++)
    {
        pre[i]=1;
        dis[i]=g[1][i];
    }
    vis[1]=1;
    dis[1]=0;
    for(i=1;i<n;i++)
    {
        double tmp=inf*1.0;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]<tmp)
            {
                tmp=dis[j];
                u=j;
            }
        }
        vis[u]=1;
        ans+=tmp;
        used[u][pre[u]]=used[pre[u]][u]=true;
        for(j=1;j<=n;j++)
        {
            if(vis[j]&&u!=j)
            {
                path[u][j]=path[j][u]=max(path[j][pre[u]],dis[u]);
            }
            if(!vis[j]&&dis[j]>g[u][j])
            {
                dis[j]=g[u][j];
                pre[j]=u;
            }
        }
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int i,j;

        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d%d%d",&d[i].x,&d[i].y,&d[i].z);
        }
        for(i=1;i<=n;i++)
        {
            for(j=i+1;j<=n;j++)
            {

                    g[i][j]=g[j][i]=dd(d[i],d[j]);
            }
        }
        double ans=prime();
        double sum=-1;
        for(i=1;i<=n;i++)
        {
            for(j=i+1;j<=n;j++)
            {
                if(used[i][j])
                {
                    sum=max(sum,1.0*(d[i].z+d[j].z)/(ans-g[i][j]));
                }
                else
                {
                    sum=max(sum,1.0*(d[i].z+d[j].z)/(ans-path[i][j]));
                }
            }
        }
        printf("%.2lf\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值