poj 3613 Cow Relays(floyd+矩阵快速幂)

Cow Relays
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8295 Accepted: 3260

Description

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi  ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

Input

* Line 1: Four space-separated integers: NTS, and E
* Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

Output

* Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

Sample Input

2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9

Sample Output

10

题意:求经过了N条边的最短路。

思路:运用矩阵可以a[i][j]表示i到j经过若干条边的最短距离,运用快速幂和floyd就可以了。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <map>
using namespace std;
const int inf=0x3f3f3f3f;
int dp[5555][5555];
char c[5555];
map<int,int>mp;
struct node
{
    int a[205][205];
};
int k,m,s,e,n;
node floyd(node a,node b)
{
    node c;
    memset(c.a,inf,sizeof(c.a));
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            for(int k=1;k<=n;k++)
            {
                c.a[i][j]=min(c.a[i][j],a.a[i][k]+b.a[k][j]);
            }
        }
    }
    return c;
}
node power(node a)
{
    node ans=a;
    k--;
    while(k)
    {
        if(k&1)ans=floyd(ans,a);
        a=floyd(a,a);
        k>>=1;
    }
    return ans;
}
int main()
{

    while(~scanf("%d%d%d%d",&k,&m,&s,&e))
    {
        mp.clear();
        node a;
        n=0;
        memset(a.a,inf,sizeof(a.a));
        for(int i=0;i<m;i++)
        {
            int w,u,v;
            scanf("%d%d%d",&w,&u,&v);
            if(!mp[u])u=mp[u]=++n;
            else u=mp[u];
            if(!mp[v])v=mp[v]=++n;
            else v=mp[v];
            a.a[u][v]=a.a[v][u]=w;
        }
      node ans= power(a);
        printf("%d\n",ans.a[mp[s]][mp[e]]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值