HDU 1060 Leftmost Digit

题目:

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3393 Accepted Submission(s): 1498
 
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2


      
      
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

思路:拿到这题,一看数据那么大,没有一点办法,想了很久,还是去看题解了。

令m=n^n

则logn(m)=n =>  lgm/lgn=n  =>  lgm=n*lgn  =>  m=10^(n*lgn);

10的整数次方得到肯定是1以开头的一个数,就要看10的小数次方得到那个数了,乘以小数次方得到的第一个数,就是我们求的数了

而且10的小数次方肯定是大于等于1,小于10的    因为10^0=1;  10^1=10;      


代码:

#include<stdio.h>
#include<math.h>
int main(){
    int t;
    scanf("%d",&t);
    long long n;
    while(t--){
        scanf("%I64d",&n);
        double x=(n*1.0)*log10(n*1.0);
        x=x-(long long)x;
        printf("%d\n",(int)pow(10.0,x));
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值