PAT (Advanced Level) Practise —— 1002. A+B for Polynomials

http://pat.zju.edu.cn/contests/pat-a-practise/1002

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

说明:利用hash表思想,开辟数组,数组的下标作为多项式的指数,对应下标的数组元素为相应系数。


PS: WA了三次,总结一下:

1. 浮点数非零的判断

//判断对应的二次项是否为0
if(fabs(coef[i] > 1e-10))
{
	++m;
}

2. scanf函数的使用:scanf("%.f", &flt)是错误的;scanf一次读入多个数据的时候格式控制字符中间可以无空格,如scanf("%d lf", &a, &b);可改为scanf("%d%lf", &a, &b);


我的代码:

#include <stdio.h>

float poly1[1000+5] = {0.0f};
float poly2[1000+5] = {0.0f};
float re[1000+5] = {0.0f};

int main()
{
	int K1, K2;
	int i, expo = 0;
	float coeff = 0.0f;
	int itemNum = 0;

	scanf("%d", &K1);
	for (i = 0; i < K1; i++)
	{
		scanf("%d%f", &expo, &coeff);
		poly1[expo] = coeff;
	}

	scanf("%d", &K2);
	for (i = 0; i < K2; i++)
	{
		scanf("%d%f", &expo, &coeff);
		poly2[expo] = coeff;
	}

	for (i = 0; i <= 1000; i++)
	{
		re[i] = poly1[i] + poly2[i];
		if (re[i])
		{
			itemNum++;
		}
	}
	printf("%d", itemNum);
	for (i = 1000; i >= 0; i--)
	{
		if (re[i])
		{
			printf(" %d %.1f", i, re[i]);
		}
	}
	printf("\n");
	return 0;
}


九度社区给出的答案:(只用一个数组即可!)

#include <cstdio>
#include <cmath>

const int MAXN = 1024;
double coef[MAXN];

int main()
{
	for (int i= 0; i < 2; i++)
	{
		int n;
		//输入第1个多项式非零项的系数
		scanf("%d", &n);
		while (n--)
		{
			int a;
			double b;
			//输入该非零项对应的指数和系数
			scanf("%d%lf", &a, &b);	
			coef[a] += b;
		}
	}
	int m = 0;
	for (int i = 0; i < MAXN; i++)
	{
		//判断对应的二次项是否为0
		if(fabs(coef[i] > 1e-10))
		{
			++m;
		}
	}
	printf("%d", m);
	for (int i = MAXN-1; i >= 0; --i)
	{
		//输出非零的二次项的次数和系数
		if(fabs(coef[i] > 1e-10))
		{
			printf(" %d %.1lf", i, coef[i]);
		}		
	}
	puts("");
	return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值