第一层第一题:你要的飞碟在这里

Your Ride Is Here

It is a well-known fact that behind every good comet is a UFO. These UFOsoften come to collect loyal supporters from here on Earth. Unfortunately, theyonly have room to pick up one group of followers on each trip. They do,however, let the groups know ahead of time which will be picked up for eachcomet by a clever scheme: they pick a name for the comet which, along with thename of the group, can be used to determine if it is a particular group's turn togo (who do you think names the comets?). The details of the matching scheme aregiven below; your job is to write a program which takes the names of a groupand a comet and then determines whether the group should go with the UFO behindthat comet.

Both the name of the group and the name of the comet are converted into anumber in the following manner: the final number is just the product of all theletters in the name, where "A" is 1 and "Z" is 26. Forinstance, the group "USACO" would be 21 * 19 * 1 * 3 * 15 = 17955. Ifthe group's number mod 47 is the same as the comet's number mod 47, then youneed to tell the group to get ready! (Remember that "a mod b" is theremainder left over after dividing a by b; 34 mod 10 is 4.)

Write a program which reads in the name of the comet and the name of thegroup and figures out whether according to the above scheme the names are amatch, printing "GO" if they match and "STAY" if not. Thenames of the groups and the comets will be a string of capital letters with nospaces or punctuation, up to 6 characters long.

Examples:

Input

Output

COMETQ

HVNGAT

GO

ABSTAR

USACO

STAY

PROGRAM NAME: ride

This means that you fill in your header with:
PROG: ride
WARNING: You must have 'ride' in this field or the wrong test data (orno test data) will be used.

INPUT FORMAT

Line 1:

An upper case character string of length 1..6 that is the name of the comet.

Line 2:

An upper case character string of length 1..6 that is the name of the group.

NOTE: The input file has a newline atthe end of each line but does not have a "return". Sometimes,programmers code for the Windows paradigm of "return" followed by"newline"; don't do that! Use simple input routines like"readln" (for Pascal) and, for C/C++, "fscanf" and"fid>>string".

NOTE 2: Because of the extracharacters, be sure to leave enough room for a 'newline' (also notated as '\n')and an end of string character ('\0') if your language uses it (as C and C++do). This means you need eight characters of room instead of six.

SAMPLE INPUT (file ride.in)

COMETQ

HVNGAT

OUTPUT FORMAT

A single line containing either the word "GO"or the word "STAY".

SAMPLE OUTPUT (file ride.out)

GO

OUTPUT EXPLANATION

Converting the letters to numbers:

C

O

M

E

T

Q

 

3

15

13

5

20

17

 

 

 

 

 

 

 

 

H

V

N

G

A

T

 

8

22

14

7

1

20

 

then calculate the product mod 47:

3 * 15 * 13 * 5 * 20 * 17 = 994500 mod 47 = 27

8 * 22 * 14 * 7 * 1 * 20 = 344960 mod 47 = 27

Because both products evaluate to 27 (when modded by 47), the mission is'GO'.

应该是一道类似于A+B的题目吧,用于熟悉oj的,不解释

/*
ID:su1q2d21
LANG:C++
TASK:ride
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#define mod 47
#define maxn 10
using namespace std;
char comet[maxn];
char group[maxn];
int main()
{
	freopen("ride.in","r",stdin);
	freopen("ride.out","w",stdout);
	int lc,lg;
	int proc=1,prog=1;
	int i;
	scanf("%s",comet);
	scanf("%s",group);
	lc=strlen(comet);
	lg=strlen(group);
	for(i=0;i<lc;i++){
		proc*=(comet[i]-'A'+1);
		proc%=mod;
	}
	for(i=0;i<lg;i++){
		prog*=(group[i]-'A'+1);
		prog%=mod;
	}
	if(proc==prog) printf("GO\n");
	else printf("STAY\n");
	return 0;
}

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值