pat1074_备份

19 篇文章 0 订阅

1074. Reversing Linked List (25)

时间限制
300 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

有点错误,明天再看看

#include <cstdio>
#include <list>
#include <algorithm>


using namespace std ;

struct node 
{
	int head ,key,end ;

	bool operator < ( const node & b ) const 
	{
		return key < b.key ;
	}
};

list<node> list2 ;

struct node list1[100001] , list3[100001] ;
int len3 = 0 , len1;

int head , L,K ;

void input()
{
	node x ;
	scanf("%d%d%d", &head ,&L , &K ) ;
	for ( int i = 0 ; i < L; i++ )
	{
		scanf( "%d%d%d", &x.head , &x.key , &x.end  ) ;

		list1[x.head] = x ;
	}
}

 

void showList2()
{
	  list<node>::iterator it = list2.begin ()  ;
	  int count = 0 ;

	  while ( count < list2.size() -1 )
	  {
		  printf("%05d %d %05d\n", it->head , it->key , it->end ) ;
		  count++ ;
		  it++ ;
	  }
	  printf("%05d %d -1", it->head , it->key ) ;
	 
}

void deal_()
{
   int h= head ;
   int mod , x ;
   int loc ;

	 while ( h != -1 )
	 {
		list3[len3++] = list1[h ];
		h= list1[h].end ;
	}
	 
	sort( list3, list3+len3) ;
	 

	x = L/K ;
	mod = L%K ;
	 
	for ( int i = 0 ; i < x ; i++ )
	{
		for (int j = 0 ; j < K ; j++ )
		{
			 loc = K*i+j ;
			
			 
			list2.push_back(list3[loc]) ;

		
			 
		}
		
		list2.reverse() ;
	}

	for ( int i = 0 ; i < mod ; i++ )
	{
		list2.push_back(list3[loc+i+1]) ;
	}

	

	 list<node>::iterator it = list2.begin() ;
	 list<node>::iterator it2 = list2.begin() ;

	 it2++ ;

	 int count = 0 ;

	 while ( count < list2.size()-1  )
	 {
		 count++ ;
		 it->end = it2->head ;
		 it++ ;
		 it2++ ;
	 }
	 
	 it->end = -1 ;

	 showList2() ;
}

int main ( void )
{
	input() ;
	deal_() ;
	 
	return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值