POJ - 3614 Sunscreen【贪心】

【题目描述】
To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they’re at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn’t tan at all…

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

【输入】

  • Line 1: Two space-separated integers: C and L
  • Lines 2…C+1: Line i describes cow i’s lotion requires with two integers: minSPFi and maxSPFi
  • Lines C+2…C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

【输出】
A single line with an integer that is the maximum number of cows that can be protected while tanning

【样例输入】
3 2
3 10
2 5
1 5
6 2
4 1

【样例输出】
2

题目链接:https://cn.vjudge.net/problem/POJ-3614

代码如下:

#include <iostream>
#include <algorithm>
using namespace std;
static const int MAXN=2500;
static const int MAXSPF=1000;
struct Node{
    int minSPF,maxSPF;
    friend bool operator < (Node p,Node q)
    {
        if(p.minSPF==q.minSPF)
            return p.maxSPF>q.maxSPF;
        return p.minSPF>q.minSPF;
    }
}cow[MAXN+10];
int sunscreen[1000+10];
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int n,m;
    cin>>n>>m;
    for(int i=1;i<=n;i++)
        cin>>cow[i].minSPF>>cow[i].maxSPF;
    int x,y;
    for(int i=1;i<=m;i++)
    {
        cin>>x>>y;
        sunscreen[x]+=y;
    }
    sort(cow+1,cow+n+1);
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        int x=cow[i].maxSPF;
        while(sunscreen[x]==0)
            x--;
        if(cow[i].minSPF<=x)
        {
            sunscreen[x]--;
            ans++;
        }
    }
    cout<<ans<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值