POJ - 3190 Stall Reservations【贪心】

【题目描述】
Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A…B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

【输入】
Line 1: A single integer, N
Lines 2…N+1: Line i+1 describes cow i’s milking interval with two space-separated integers.

【输出】
Line 1: The minimum number of stalls the barn must have.

Lines 2…N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

【样例输入】
5
1 10
2 4
3 6
5 8
4 7

【样例输出】
4
1
2
3
2
4

【样例解释及数据规模】
Explanation of the sample:

Here’s a graphical schedule for this output:

Time 1 2 3 4 5 6 7 8 9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 … c2>>>>>> c4>>>>>>>>> … …

Stall 3 … … c3>>>>>>>>> … … … …

Stall 4 … … … c5>>>>>>>>> … … …
Other outputs using the same number of stalls are possible.

题目链接:https://vjudge.net/problem/POJ-3190

代码如下:

#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;
static const int MAXN=1000000;
struct Node{
    int x,y,cnt,num;
    friend bool operator < (Node a,Node b)
    {
        if(a.y==b.y)
            return a.x>b.x;
        return a.y>b.y;
    }
}cow[MAXN+10];
bool cmp(Node p,Node q)
{
    if(p.x==q.x)
        return p.y<q.y;
    return p.x<q.x;
}
bool cmp1(Node p,Node q)
{
    return p.num<q.num;
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int n;
    cin>>n;
    priority_queue<Node> Q;
    for(int i=1;i<=n;i++)
    {
        cin>>cow[i].x>>cow[i].y;
        cow[i].num=i;
    }
    sort(cow+1,cow+n+1,cmp);
    int ans=0;
    cow[1].cnt=1;
    Q.push(cow[1]);
    for(int i=2;i<=n;i++)
        if(cow[i].x>Q.top().y)
        {
            cow[i].cnt=Q.top().cnt;
            Q.pop();
            Q.push(cow[i]);
        }
        else
        {
            cow[i].cnt=Q.size()+1;
            Q.push(cow[i]);
        }
    sort(cow+1,cow+n+1,cmp1);
    cout<<Q.size()<<endl;
    for(int i=1;i<=n;i++)
        cout<<cow[i].cnt<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值