[kuangbin]专题一 简单搜索 Find The Multiple POJ - 1426【BFS】

【题目描述】
Given a positive integer n,write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1.You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
给定一个正整数n,请编写一个程序来寻找n的一个非零的倍数m,这个m用十进制表示时每一位上只包含0或者1。你可以假设n不大于200且m不多于100位。

【输入】
The input file may contain multiple test cases.Each line contains a value of n (1 <= n <= 200).A line containing a zero terminates the input.
输入包含多组数据,每组数据仅一行,只包含一个正整数n (1 <= n <= 200)。

【输出】
For each value of n in the input print a line containing the corresponding value of m.The decimal representation of m must not contain more than 100 digits.If there are multiple solutions for a given value of n,any one of them is acceptable.
对于输入的每组n,都输出任一符合条件的m。即使有多个符合条件的m,你也只需要输出一个即可。

【样例输入】
2
6
19
0

【样例输出】
10
100100100100100100
111111111111111111

题目链接:https://cn.vjudge.net/problem/POJ-1426

dfs,bfs均可,题干吓人,假装有100位,实际上long long就能过

代码如下:

#include <iostream>
#include <queue>
using namespace std;
typedef unsigned long long ULL;
int n;
void bfs(ULL x)
{
    queue<ULL> Q;
    Q.push(x);
    while(!Q.empty())
    {
        ULL now=Q.front();
        Q.pop();
        if(now%n==0)
        {
            cout<<now<<endl;
            return;
        }
        Q.push(10ull*now);
        Q.push(10ull*now+1);
    }
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    while(cin>>n && n) bfs(1);
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值