04-树6 Complete Binary Search Tree

04-树6 Complete Binary Search Tree(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.The right subtree of a node contains only nodes with keys greater than or equal to the node's key. Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (1000). Then Ndistinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

解题过程(参考自MOOC):

题目的意思就是将输入的数组构成完全二叉搜索树并用层序遍历将其输出,这里我们采用数组的方式,因为对于数组而言,层序遍历相当遍历数组,这对输出来讲比较便利。

程序分2个模块:

1.    getLength()模块:

    -    该模块主要的功能是获得左子树结点的个数。

2.    solve()模块:

    -    该模块主要是用于递归将层序遍历的结果存入数组outArr中

通过对输入的数组进行从小到大排序,然后通过计算左子树的结点个数L,我们可以得到根结点必然在数组中的"起始位置+L+1"的位置上(因为二叉搜索树的左边小于跟结点右边大于根结点)

程序:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>

using namespace std;
int outArr[1001];
int InArr[1001];

int getLength(int n)
{
	int H = int(log2(n+1));
	int X = n + 1 - pow(2, H);	// 最后一层结点个数.
	X = X > pow(2, H-1) ? pow(2, H-1) : X;	// 只计算最后一层左子树的个数
	int L = pow(2, H-1) - 1 + X;		// 左子树结点数
	return L;
}

void solve(int ALeft, int ARight, int Troot)
{	/* Aleft表示数组起始位置,Aright表示数组终止位置,Troot表示在outputArr中的下标 */
	int n = ARight - ALeft + 1;
	if (n == 0) return;		// 当L为0,即此时已经为根结点就终止
	int L = getLength(n);
	outArr[Troot] = InArr[ALeft+L]; 
	/* 根结点从0开始,所以根结点的左子树的编号为 Troot*2+1
		根结点的右子树编号为 Troot*2+2				*/	
	int LeftTroot = Troot * 2 + 1;		
	int RightTroot = Troot * 2 + 2;
	/* 对左右子树进行递归 */
	solve(ALeft, ALeft+L-1, LeftTroot);
	solve(ALeft+L+1, ARight, RightTroot);
}

int main(int argc, char const *argv[])
{
	int N;
	scanf("%d\n", &N);
	for (int i = 0; i < N; i++)
		scanf("%d", &InArr[i]);
	sort(InArr, InArr + N);    // 排序
	solve(0, N-1, 0);
	for (int i = 0; i < N; i++)
	{	
		if (i != 0)
			printf(" ");
		printf("%d", outArr[i]);
	}
	return 0;
}
如果对您有帮助,就点给赞呗~
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值