10151

Recurrence Relations
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 710, Accepted users: 681
Problem 10151 : No special judgement
Problem description
Recurrence relations are where a function is defined in terms of itself and maybe other functions as well. in this problem, we have two functions of interest:

F (N) = F (N - 1) + G (N - 1) ; F (1) = 1

G (N) = G (N - 1) + G (N - 3) ; G (1) = 1, G (2) = 0, G (3) = 1

For a given value of N, compute F (N).

Input
Each line of input will have exactly one integer, 57 > = N > 0. 
Output
For each line of input, output F(N). 
Sample Input
1
4
57
Sample Output
1
3
2035586497

#include <stdio.h>
int main()
{
    int d,i=4,j=2;
    int F[60],G[60];
    G[1]=G[3]=1;G[2]=0;
    F[1]=1;
    for (;i<60;i++)
    {
        G[i]=G[i-1]+G[i-3];
        F[i-2]=F[i-3]+G[i-3];
    }
    while(scanf("%d",&d)!=EOF)
    {
        printf("%d\n",F[d]);
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值