13298

21
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB
Total submit users: 68, Accepted users: 48
Problem 13298 : No special judgement
Problem description

As a youth of 21st century, Ming loves the number 21. One day, he met a problem. By given a positive integer he must calculate how many n! can be divided exactly by 21 at the same time? For example, 7! can only be divided by 21 exactly 1 times at the same time. If n is little, we can directly calculate the results simple. However, n is very large, Ming’s math is poor. Can you help Ming to solve this problem?

Input

Input a integer number n, 0 < n < 109, end with EOF.

Output

Output the result.

Sample Input
7
9
14
Sample Output
1
1
2
Problem Source
HNU Contest 

#include <stdio.h>

int main()
{
	int n;
	int a=0;
	while( scanf("%d",&n) != EOF )
	{
		while( (n/7) >= 1 ) {
			a=a+n/7;
			n=n/7;
		}
		printf("%d\n",a);
		a=0;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值