多校练习赛6 HDU4605 unshuffle

73 篇文章 21 订阅
56 篇文章 0 订阅

Unshuffle

                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                        Total Submission(s): 433    Accepted Submission(s): 151
                                                                                                         Special Judge


Problem Description
A shuffle of two strings is formed by interspersing the characters into a new string, keeping the characters of each string in order. For example, MISSISSIPPI is a shuffle of MISIPP and SSISI. Let me call a string square if it is a shuffle of two identical strings. For example, ABCABDCD is square, because it is a shuffle of ABCD and ABCD, but the string ABCDDCBA is not square.  
Given a square string, in which each character occurs no more than four times, unshuffle it into two identical strings.
 

Input
First line, number of test cases, T.  
Following are 2*T lines. For every two lines, the first line is n, length of the square string; the second line is the string. Each character is a positive integer no larger than n.  

T<=10, n<=2000.
 

Output
T lines. Each line is a string of length n of the corresponding test case. '0' means this character belongs to the first string, while '1' means this character belongs to the second string. If there are multiple answers, output any one of them.
 

Sample Input
  
  
1 8 1 2 3 1 2 4 3 4
 

Sample Output
  
  
00011011
 

Source
 

Recommend
zhuyuanchen520
 


其实这道很无语。。  当时看过的人太少。。估计是被多校给整怕了。题都不敢尝试。  没想到诶。 竟然 暴搜78MS就过掉了。  看题解是用的2-SAT,表示淡淡的忧伤。

多校的第一题也是。公式都推出来了。竟然是数组开太小了。   看来是自己心理素质不够强。 多尝试就好了。用不同的方法,总会过去的。以后做题得勇敢点了。

一步一个脚印,就当被上了堂课。  人生也该是如此吧。多尝试,不要拘泥,不要害怕。。


暴搜。。没什么好讲的。。。就是开数组存个答案。


#include <cstdio>
#include <cstdlib>
int n;
char ans[4000];
int s[4000];
int a[4000];
bool flag;
void dfs(int x,int y,int step){
    if(flag) return;
    if(x>(n>>1)||y>(n>>1))
        return;
    if(step==n){
        flag=true;
        return;    
    }
    ans[step]='0';
    s[x]=a[step];
    dfs(x+1,y,step+1);
    if(flag) return;
    if(s[y]==a[step]){
        ans[step]='1';
        dfs(x,y+1,step+1);
    }
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",a+i);
        }
        flag=false;
        dfs(0,0,0);
        for(int i=0;i<n;i++)
            printf("%c",ans[i]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值