Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.




Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

代码如下

#include<stdio.h>
#include<string.h>
using namespace std;
bool prime[42];  //是素数 标记为false 不是素数 标记为true
int n;
int a[25];
int book[25];
void Getprime(){      //素数筛选法
    int i,j;
    prime[0]=prime[1]=true;
    for(i=2;i<=20;i++){
        if(prime[i]==false)  //如果i是素数 那么i 的倍数均不是素数
        for(j=2;j*i<=40;j++){
            prime[j*i]=true;
        }
    }
}
void show(int n){
    int i;
     for(i=0;i<n-1;i++)
            printf("%d ",a[i]);
        printf("%d\n",a[i]);
}
void Dfs(int step){
    if(step==n&&!prime[a[n-1]+a[0]]){
        show(n);
        return;
    }
    int i;
    for(i=2;i<=n;i++){
        if(book[i]==0&&!prime[i+a[step-1]]){
            a[step]=i;
            book[i]=1;
            Dfs(step+1);
            book[i]=0;
        }
    }
}
int main(){
    Getprime();
    int k=1;
    while(scanf("%d",&n)!=EOF){
        memset(a,0,sizeof(a));
        memset(book,0,sizeof(book));
        a[0]=1;
        book[1]=1;
        printf("Case %d:\n",k);
        k++;
        Dfs(1);
        printf("\n");
    }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值