Substrings

     You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
Input
    The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
Output
    There should be one line per test case containing the length of the largest string found.
Sample Input

    2
    3
    ABCD
    BCDFF
    BRCD
    2
    rose
    orchid

Sample Output

    2
    2
题意:
求所给字符串公共子串的最大长度

分析:暴力,strstr函数用法

代码:

#include<stdio.h>
#include<string.h>
using namespace std;
char str[105][105],s1[105],s2[105];
int n;
int mint;
int Getstr(){//得到字符串并找到最短字符串 
	int x=0;
	for(int i=0;i<n;i++){
		scanf("%s",str[i]);
		int len=strlen(str[i]);
		if(len<mint){
			x=i;
			mint=len;
		}
	}
	return x;
}
int main(){
	int T;
	int flag,MAX;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		mint=1000;
		int x = Getstr();
		int len=strlen(str[x]);
		MAX=0;
		for(int i=0;i<len;i++){//标本串的头 
			for(int j=i;j<len;j++){//标本串的尾 
				for(int k=i;k<=j;k++){ //复制子字符串 
					s1[k-i]=str[x][k];//顺字符串 
					s2[j-k]=str[x][k];//逆字符串 
				}
				s1[j-i+1]=s2[j-i+1]='\0';
				int l=strlen(s1);
				flag=1;
				for(int k=0;k<n;k++){//判断是否是所有字符串的子串 
					if(!strstr(str[k],s1)&&!strstr(str[k],s2)){
						flag=0;
						break;
					}
				}
				if(l>MAX&&flag) MAX=l;
			}
		}
		printf("%d\n",MAX);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值