最长回文子串

回文串是指aba、abba、cccbccc、aaaa这种左右对称的字符串。
输入一个字符串Str,输出Str里最长回文子串的长度。

Input
输入Str(Str的长度 <= 1000)
Output
输出最长回文子串的长度L。
Sample Input
daabaac
Sample Output
5
代码:dp[j][i]   j到i是回文字符串
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N = 1005;
char str[N];
int dp[N][N];
int solve(int n){
	int maxt=0;
	for(int i=0;i<n;i++){
		int j=i;
		while(j>=0){
			if(str[i]==str[j]&&(i-j<2||dp[j+1][i-1])){
				dp[j][i]=1;
				maxt=max(maxt,i-j+1);
			}
			j--;
		}
	}
	return maxt;
}
int main(){
	scanf("%s",str);
	int len=strlen(str);
	printf("%d\n",solve(len));
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值