Solve equation FZU - 2102(进制转化)

You are given two positive integers A and B in Base C. For the equation:

A=k*B+d

We know there always existing many non-negative pairs (k, d) that satisfy the equation above. Now in this problem, we want to maximize k.

For example, A="123" and B="100", C=10. So both A and B are in Base 10. Then we have:

(1) A=0*B+123

(2) A=1*B+23

As we want to maximize k, we finally get one solution: (1, 23)

The range of C is between 2 and 16, and we use 'a', 'b', 'c', 'd', 'e', 'f' to represent 10, 11, 12, 13, 14, 15, respectively.


Input

The first line of the input contains an integer T (T≤10), indicating the number of test cases.

Then T cases, for any case, only 3 positive integers A, B and C (2≤C≤16) in a single line. You can assume that in Base 10, both A and B is less than 2^31.

Output
For each test case, output the solution “(k,d)” to the equation in Base 10.
Sample Input
3
2bc 33f 16
123 100 10
1 1 2
Sample Output
(0,700)
(1,23)
(1,0)




题意:给两个字符串a,b,一个数字n,表示a,b是n进制数,求使得a=k*b+c成立时   k最大的k,b的结果;

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<map>
using namespace std;
map<char,int>mp;
void init(){  //初始化 
	int i;
	for(i=0;i<10;i++)
	   mp['0'+i]=i;
	for(int j=0;i<16;i++,j++)
	   mp['a'+j]=i;
}
int solve(string str,int n){  //进制转化 
	int ans=0;
	for(int i=0;i<str.length();i++)
	   ans=ans*n+mp[str[i]];
	return ans;
}
int main(){
	int T;
	scanf("%d",&T);
	init();
	while(T--){
		string a,b;
		int n;
		cin>>a>>b>>n;
		int A=solve(a,n);
		int B=solve(b,n);
		printf("(%d,%d)\n",A/B,A%B);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值